1. <address id="ft1gd"></address>
      <source id="ft1gd"></source>

      第一股票公式网,股票公式,股票,公式下载,指标公式 设为首页加入收藏
      你的位置:第一股票公式网股票公式源码极品变色MACD指标源码

      极品变色MACD指标源码

      通达信 极品变色MACD 源码:

      DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
      DEA:EMA(DIFF,9);
      MACD:=2*(DIFF-DEA);
      STICKLINE(MACD>=0,MACD,0,2,1),COLORF00FF0;
      STICKLINE(MACD<0,MACD,0,2,1),COLORWHITE;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00AAFF;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00BBFF;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00CCFF;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00DDFF;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00EEFF;
      STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00FFFF;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0000AA;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0011BB;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0022CC;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0033DD;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0044EE;
      STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0055FF;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORAA00BB;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORBB11BB;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORCC22BB;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORDD33BB;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLOREE44BB;
      STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFF55BB;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFAA00;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFBB11;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFCC22;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFDD33;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFEE44;
      STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFFF55;
      IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;
      IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;
      IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;
      IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
      低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
      STICKLINE(低位金叉,0,-0.18,2,0),COLORYELLOW;
      DRAWTEXT(低位金叉,-0.1,' 低位金叉'),COLORYELLOW;
      JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
      二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
      STICKLINE(二次金叉,0,-0.18,2,0),COLORFF00FF;
      DRAWICON(二次金叉,DEA*1.04,13) ;
      DRAWTEXT(二次金叉,-0.1,' 二次金叉'),COLORFF00FF;
      A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
      底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
      STICKLINE(底背离,0,0.13,2,0),COLOR00FF00;
      DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
      DRAWTEXT(底背离,0.1,' 底背离'),COLOR00FF00;
      A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
      顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
      DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;

        精品股票公式

        网友评论温馨提示:任何网友发表的言论必须符合国家法律,否则予以删除!

           评论摘要(共 0 条) 请登陆或注册后再发表评论!

             

              验证码:

        猜你喜欢

        网友爱看

        学了又学

        国产精品第一页,亚洲老熟女性亚洲,奇米777四色影视在线看,八戒网站免费观看视频 网站地图